Important Notice for Cradlepoint Device Users

Security Update: Meltdown and Spectre vulnerabilities

Two new vulnerabilities that affect many modern microprocessors were published on January 3rd, 2018. The first vulnerability, called Meltdown, affects only Intel CPU’s and can be fixed with an operating system patch.  The second, called Spectre, affects CPU’s from AMD and ARM. It requires a CPU design change and cannot be fixed in software.

Cradlepoint routers are not affected by either vulnerability.

Cradlepoint’s primary cloud provider has patched their servers to mitigate potential effects to NetCloud Manager (NCM) and NetCloud Perimeter (NCP).

For more information on the related CVEs and links to supporting articles, please click here.

For questions regarding either of these important notices, contact Cradlepoint Support by logging into Cradlepoint Connect and initiating a Support Ticket.  

Announcement Date: 
Tuesday, January 9, 2018