COVID-19 EMERGENCY RESPONSE We stand with our partners, business customers, and especially our first and emergency responders on the front lines of this crisis. Read More

CPSEC-13: Open SSL “POODLE” Vulnerability

October 19, 2018

Summary: The OpenSSL project released an advisory on October 15th, 2014, which describes the newly discovered vulnerability (CVE-2014-3566). Some Cradlepoint products utilize OpenSSL and are affected by this advisory.

Mitigation: Involved upgrading to firmware version 5.2.4 or newer. For more information or instructions on these mitigation steps, consult the Cradlepoint Knowledgebase or contact Cradlepoint Support.

Knowledge Article

CVE-2014-3566 NIST/NVD Detail